Puppet contains a flaw that is triggered when parsing a specially crafted Delete request. This may allow a remote authenticated attacker to delete arbitrary files. This may also allow a denial of service attack.
Upgrade to Puppet to version 2.6.17 or 2.7.18 or higher and Puppet Enterprise to version 2.5.2 or higher, as they have been reported to fix this vulnerability. In addition, the vendor has released a patch for some older versions.
The database information may change without any notice. Use of the information constitutes acceptance for use in an AS IS condition, and there are NO
warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the copyright
holder or distributor (OSVDB or OSF) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.