OSVDB ID: 72337

Title: Adobe Flash Player Boundary Error Arbitrary Code Execution (2011-0623)

Info

Disclosure

May 12, 2011

Discovery

Unknown

Dates

Exploit

Unknown

Solution

May 12, 2011

Description

Adobe Flash Player contains an unspecified boundary error that may allow an attacker to execute arbitrary code. No further details have been provided.

Classification

Location: Remote / Network Access
Attack Type: Input Manipulation
Impact: Loss of Integrity
Solution: Upgrade
Exploit: Exploit Private
Disclosure: Vendor Verified

Solution

Upgrade to version 10.3.181.14 or higher for Windows, Macintosh, Linux and Solaris, 11.0.696.68 or higher for Chrome, or 10.3.185.21 or higher for Android, as they have been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Products

Adobe Systems Incorporated

Flash Player

10.2.159.1

Flash Player for Android

10.2.157.51

Flash Player for Chrome

10.2.154.28

Shockwave Player

11.6.8.638

Google, Inc.

Chrome

11.0.696.65

References

Credit

Unknown or Incomplete



Direct URL: http://osvdb.org/72337