OSVDB ID: 3228

Title: ActiveCampaign KnowledgeBuilder index.php page Parameter Remote File Inclusion

Info

Disclosure

Dec 24, 2003

Discovery

Unknown

Dates

Exploit

Dec 24, 2003

Solution

Unknown

Description

KnowledgeBuilder contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to index.php not properly sanitizing user input supplied to the 'page' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Classification

Location: Remote / Network Access
Attack Type: Input Manipulation
Impact: Loss of Integrity
Exploit: Exploit Public
OSVDB: Web Related

Solution

Currently, there are no known workarounds or upgrades to correct this issue. However, ActiveCampaign has released a patch to address this vulnerability.

Products

ActiveCampaign, Inc.

KnowledgeBuilder

3.0.01
2.1.04
2.1.00
2.0.01
2.2.01

References

Credit

  • Zero X - zero-xlinuxmail.org - Lobnan
  • Francisco Alisson - dominusvisclick21.com.br -


Direct URL: http://osvdb.org/3228