17166 : FlatNuke referer.php Crafted Referer Arbitrary PHP Code Execution
Printer | http://osvdb.org/17166 | Email This | Edit Vulnerability

Views This Week Views All Time Added to OSVDB Last Modified Modified (since 2008) Percent Complete
2 801 almost 9 years ago about 6 years ago 0 times 90%

Timeline

Disclosure Date
2005-06-06
Time to Exploit
15 days

Description

FlatNuke contains a flaw that may allow a malicious user to execute arbitrary PHP command. The issue is due to insufficient input validation in the referer.php script. When an attacker first sends a specially crafted request with a spoofed referer field to the website, then directly accesses the referer.php script, the website will execute the PHP commands in the referer field.

Classification

Location: Remote / Network Access
Attack Type: Input Manipulation
Impact: Loss of Integrity
Exploit: Exploit Public
OSVDB: Web Related

Solution

Upgrade to version 2.5.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Products

FlatNuke
FlatNuke
2.5.3

References

Credit

  • Tiger Team Security - ttswebyahoo.it - Tiger Team Security

CVSSv2 Score

CVSSv2 Base Score = 7.5
Source: nvd.nist.gov | Generated: 2005-06-09 | Disagree?

Access_vector_2 Access_complexity_2 Authentication_2 Confidentiality_impact_1 Integrity_impact_1 Availability_impact_1

Comments

No Comments.

The database information may change without any notice. Use of the information constitutes acceptance for use in an AS IS condition, and there are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the copyright holder or distributor (OSVDB or OSF) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

© Copyright 2002 - 2014 Open Sourced Vulnerability Database (OSVDB), All Rights Reserved.
Privacy Statement - Terms of Use